Apple Macintosh OS X Commands

This group of pages has my contributions to the Internet community.

This document lists the OS X-specific commands added or substantially tailored by Apple. The list is as of OS 10.2.6.

It does not list commands that are only relevant to developers (e.g., C compilers).

  • /Developer/Tools/BuildStrings
  • /Developer/Tools/CpMac
  • /Developer/Tools/Derez
  • /Developer/Tools/GetFileInfo
  • /Developer/Tools/MergePef
  • /Developer/Tools/MvMac
  • /Developer/Tools/ResMerger
  • /Developer/Tools/Rez
  • /Developer/Tools/RezWack
  • /Developer/Tools/SetFile
  • /Developer/Tools/SplitForks
  • /Developer/Tools/UnRezWack
  • /System/Library/CoreServices/Setup Assistant
  • /usr/bin/chflags
  • /usr/bin/defaults
  • /usr/bin/drutil
  •     /usr/bin/drutil tray eject -drive internal
  •     /usr/bin/drutil tray close -drive internal
  • /usr/bin/hdiutil
  • /usr/bin/lsbom
  • /usr/bin/open
  • /usr/bin/osacompile
  • /usr/bin/osascript, especially osascript -e "say"
  • /usr/bin/pbpaste
  • /usr/bin/plutil
  • /usr/bin/redo_prebinding
  • /usr/bin/resetpassword
  • /usr/bin/say
  • /usr/bin/sips
  • /usr/bin/update_prebinding
  • /usr/libexec/authopen
  • /usr/sbin/asr
  • /usr/sbin/bless
  • /usr/sbin/diskutil repairPermissions /
  • /usr/sbin/dot_clean
  • /usr/sbin/dsconfigad
  • /usr/sbin/ioreg
  • /usr/sbin/kextfind
  • /usr/sbin/lookupd
  • /usr/sbin/networksetup
  • /usr/sbin/nvram
  • /usr/sbin/pkgutil
  • /usr/sbin/screencapture
  • /usr/sbin/softwareupdate
  • /usr/sbin/systemsetup

and

  • netinfod(8) - NetInfo daemon
  • nibindd(8) - NetInfo binder
  • nicl(1) - NetInfo command line utility
  • nidomain(8) - NetInfo domain utility
  • nidump(8) - extract text or flat-file-format data from NetInfo
  • nifind(1) - find a directory in the NetInfo hierarchy
  • nigrep(1) - search for a regular expression in the NetInfo hierarchy
  • niload(8) - load text or flat-file-format data into NetInfo
  • nireport(1) - print tables from the NetInfo hierarchy
  • niutil(1) - NetInfo utility

Please send additions/changes to me. I am Craig A. Finseth.

Spotlight Commands

  • mdfind
  • mdls
  • mdimport
  • mdutil

Unix Commands

If you aren't familiar with Unix but can find a use for the above, you will probably want to be aware of these standard Unix commands:

  • alias
  • bless
  • find
  • man
  • sudo
  • whereis

AppleScript Debugging Environment Variables

Do the following from a Terminal command line for a csh or tcsh:

  • setenv AEDebug 1
  • setenv AEDebugSends 1
  • setenv AEDebugReceives 1

Or do this for a sh, ksh, or bash shell:

  • export AEDebug=1
  • export AEDebugSends=1
  • export AEDebugReceives=1

Note that the default Terminal shell for OS X 10.0 through 10.2 is tcsh, but they changed it to bash starting with 10.3.

Safari Debug Menu

Enable by entering this command from a Terminal command line:

defaults write com.apple.Safari IncludeDebugMenu 1

and disable by:

defaults write com.apple.Safari IncludeDebugMenu 0


Speed Up Sheets

defaults write NSGlobalDomain NSWindowResizeTime time

where time is a time in seconds from, say, .001 to 2.


Set Default Umask

defaults write /Library/Preferences/.GlobalPreferences NSUmask #

defaults write -g NSUmask -int #

The first sets the global, system default and the second sets the per-user default. The NSUmask may not be honored by software that has not been adapted for OS X. # is the umask (per umask(2)). It may, however, be in decimal instead of octal.


Set Whether to Show Hidden Files

defaults write com.apple.Finder AppleShowAllFiles YES

and, to put it back:

defaults write com.apple.Finder AppleShowAllFiles NO

You'll have to restart the Finder (or log out and log back in) for this to take effect.


Set Login Window "MOTD" Text

Edit:

/Library/Preferences/com.apple.loginwindow.plist

Between the <dict>/</dict> tags, insert a <key>...</key> and <string>...</string> pair as:

	<dict>
		...
	<key>LoginwindowText</key>
	<string>MOTD TEXT</string>
		...
	</dict>

Creative Contributions

Others' Contributions

Apple-related

Internet FAQs

Code

“How-Tos”

Data

Neat


 
 

I am Craig A. Finseth.

Back to Home.

Back to top.

Last modified Wednesday, 2013-01-02T18:16:58-06:00.